Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Killing floor package trouble
#1
Hi all
I wanna decompile files .u from killing floor system folder and got the next error message :

Invalid package signature! Sad

with native tablelist UT2004

help me , please .

Thanks

#2
Hey, I'm sorry for this issue.

The developers of Killing Floor have changed the signature of their files so existing decompilers such as UTPT couldn't decompile those packages, well technically they can, it just isn't aware of the KF signature.

So well, you can work around this by changing the signature of the file using a hex editor.

Open a Killing Floor package with a hex editor, any will do. Then replace the first 4 bytes e.g. C2 83 2A 9E with C1 83 2A 9E or just the first C2 with C1 Tongue Now UE Explorer will recognize the signature.

I'll try to implement a feature which lets you add more signatures via options later!
#3
Thanks Eliot. Your work is awesome. I wait yours new updates
#4
Thanks Big Grin
#5
Fixed this issue. UE Explorer will now ask if you want to still continue if the signature is unknown!
#6
(05-21-2012, 10:35 AM)eliot Wrote:  Fixed this issue. UE Explorer will now ask if you want to still continue if the signature is unknown!

Cool. I will download the last release now Thanks Eliot Smile
#7
It's not yet released sorry :p Need to improve the support for some games before it's ready, but I haven't yet worked on that.
#8
This was solved since 1.1. Closing thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)