The following warnings occurred:
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit
Warning [2] Undefined array key "previewpost" - Line: 164 - File: inc/plugins/htmlposts.php PHP 8.2.21 (Linux)
File Line Function
/inc/class_error.php 153 errorHandler->error
/inc/plugins/htmlposts.php 164 errorHandler->error_callback
/inc/class_plugins.php 142 htmlposts_parse
/inc/class_parser.php 153 pluginSystem->run_hooks
/inc/functions_post.php 829 postParser->parse_message
/showthread.php 1121 build_postbit




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.3.1.0 Unhandled Exception.
#1
When updating from 1.3.0 to 1.3.1.0 I get an error when starting the application, that states:

"Unhandled exception has occured in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

The system cannot find the file specified. (Exception from HRESULT: 0x80070002)."

The full details are as below.

"
************** Exception Text **************
System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4515.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
UE Explorer
    Assembly Version: 1.3.1.0
    Win32 Version: 1.3.1
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/UE%20Explorer.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4550.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4536.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4390.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4590.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4190.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
Storm.TabControl
    Assembly Version: 1.0.0.0
    Win32 Version: 3.0.153.1
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/Storm.TabControl.DLL
----------------------------------------
PresentationCore
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4590.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/PresentationCore/v4.0_4.0.0.0__31bf3856ad364e35/PresentationCore.dll
----------------------------------------
WindowsBase
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4590.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/WindowsBase/v4.0_4.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
Eliot.UELib
    Assembly Version: 1.3.1.0
    Win32 Version: 1.3.1
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/Eliot.UELib.DLL
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Eliot.Utilities
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/Eliot.Utilities.DLL
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4084.0 built by: NET48REL1
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
AutoUpdater.NET
    Assembly Version: 1.7.6.0
    Win32 Version: 1.7.6.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/AutoUpdater.NET.DLL
----------------------------------------
Microsoft.Web.WebView2.WinForms
    Assembly Version: 1.0.1462.37
    Win32 Version: 1.0.1462.37
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/Microsoft.Web.WebView2.WinForms.DLL
----------------------------------------
Microsoft.Web.WebView2.Core
    Assembly Version: 1.0.1462.37
    Win32 Version: 1.0.1462.37
    CodeBase: file:///C:/Program%20Files%20(x86)/Eliot/UE%20Explorer/Microsoft.Web.WebView2.Core.DLL
----------------------------------------
System.Deployment
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.4270.0 built by: NET48REL1LAST_C
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Deployment/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
----------------------------------------

"
This error occurs every time I start the program.
This error doesn't occur when using the 1.3.0 version.

If you ignore the error and continue to the program the "Homepage" tab is just blank. There's still a lot of classes/functions that don't quite deserialize properly in the game I'm working on, so I can't say for sure if the error it's causing any other problems on that end.
Reply
#2
Strange, does it tell you the file that cannot be found?
Reply
#3
(01-16-2023, 07:04 AM)eliot Wrote: Strange, does it tell you the file that cannot be found?

It does not.

Here's a link to a ZIP with a screenshot of the error, and a copy of my install. Hopefully that helps.
https://drive.google.com/file/d/17H2_lyz...share_link
Reply
#4
Thanks, your copy does run fine on my end.

Have you tried running the app as an administrator?
Reply
#5
(01-18-2023, 03:31 AM)eliot Wrote: Thanks, your copy does run fine on my end.

Have you tried running the app as an administrator?

Have tried running it as admin, as well as installing it as admin. Same result. Is there supposed to be something in AppData\Roaming\EliotVU\UE Explorer\1.3.1 maybe? As that folder is completely empty.
Reply
#6
I think I found the culprit, the Homepage requires you to install the prerequisite https://developer.microsoft.com/en-us/mi.../webview2/

By uninstalling webview2 I was able to reproduce this error.
Reply
#7
Additionally, if you install from the provided setup.exe instead of the .msi file (See https://github.com/UE-Explorer/UE-Explor.../tag/1.3.1), you will be prompted to install the WebView Runtime Wink

Unfortunately the auto-updater only updates from the .msi file!
Reply
#8
(01-31-2023, 06:15 AM)eliot Wrote: I think I found the culprit, the Homepage requires you to install the prerequisite https://developer.microsoft.com/en-us/mi.../webview2/

By uninstalling webview2 I was able to reproduce this error.

(01-31-2023, 06:44 AM)eliot Wrote: Additionally, if you install from the provided setup.exe instead of the .msi file (See https://github.com/UE-Explorer/UE-Explor.../tag/1.3.1), you will be prompted to install the WebView Runtime Wink

Unfortunately the auto-updater only updates from the .msi file!
Oh dang, just saw this. Yeah, installing webview2 solved the error. Great work!

Just want to clerify; When you say auto-updater only updates from the .msi file, do you mean that you have to install from .msi to get the auto update feature to work?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)